Instalar vim desde los ports II

By 7 de agosto de 2006 BSD, DragonFlyBSD One Comment

fulllogo.gifDragonFly BSD es una distribución de BSD que, desde, siempre ha prometido mucho.

Podemos encontrarnos el caso de que al instalar desde los ports el programa 'vim' éste nos explote en las manos con un fabuloso mensaje error como este:

/usr/libexec/binutils212/elf/ld: cannot find -lXThrStub *** Error code 1 Stop in /usr/ports/x11/XFree86-4-libraries/work/xc/lib/X11. *** Error code 1 Stop in /usr/ports/x11/XFree86-4-libraries/work/xc/lib. *** Error code 1 Stop in /usr/ports/x11/XFree86-4-libraries. *** Error code 1 Stop in /usr/ports/x11-toolkits/gtk12. *** Error code 1 Stop in /usr/ports/editors/vim.978

Para paliar esto deberemos instalar sin el soporte X11 de la siguiente manera:

# cd /usr/ports/editors/vim && make install clean WITHOUT_X11="YES"

En todos los paquetes podemos ver según que opciones tenemos rastreando en el Makefile del mismo.

One Comment

Leave a Reply

Your email address will not be published.